在很多代码里面,某个方法的参数名称经常会用paylaod来命名。例如:

mutations: {
  increment (state, payload) {
    state.count += payload.amount
  }
}

之前一直纠结这个单词的意思,直接翻译的结果是“载荷”,结果又被这个中文词汇搞的一头雾水。为什么不用data之类的呢?“载荷”到底是个什么鬼?

通过搜索引擎大量的查找,看了几篇文章之后得出结论,载荷就是一批数据里面有用的那一部分。
举个例子:
你点了一份炸鸡,快递小哥的摩托车和人和炸鸡等全加起来是一个重量,这叫load(总装载量)。而你付费的那一部分重量就叫pay-load。也就是你点的炸鸡,“炸鸡”就是“载荷”。

转载请注明来自:刘晓帆的博客

发表评论

电子邮件地址不会被公开。 必填项已用*标注